从 0.x 时代开始用的这货,竟然弄了个断崖式升级喵喵喵!所有 1.x 之前的数据无法直接导入到 2.x 喵!

于是升级流程就变成了(卧槽这货的编辑器支持中文输入法也有问题喵个咪……)

  1. 将0.x时代的所有博文用 JSON 导出(前提是你的 0.x 博客还能启动,此时推荐NVM来安装 node 6.x.x LTS 版本启动);
  2. 安装 Ghost Cli 工具(建议 nvm 切换到 8.x.x LTS 版本);
  3. 安装 Ghost 1.x 版本(只是过一遍数据,本地即可) ghost install local --v1 --db=sqlite3
  4. 在 1.x 的控制台上导入 0.x 时代的 JSON 文件,再导出一份 1.x 的JSON文件备份;
  5. 尝试直接升级 Ghost ghost update ,如果成功应该能升级到 2.x 的当前版本;
  6. 如果 步骤5 大量出错不可解,新建个文件夹再次安装 Ghost 当前版本 ghost install 然后尝试导入 步骤4 导出的 1.x JSON 备份文件;

如果以上都不行,那还是放弃这个平台比较好喵……我导入后只是不少文章顺序混乱了,但是都还在喵……

参考链接🔗: